The issue has been identified and a fix is being implemented.
Posted Mar 27, 2026 - 15:01 UTC
Investigating
After further review this morning, we’ve observed some anomalies in reporting, so we’ve moved the incident back to Investigating while our team continues to dig into the root cause. We’ll keep you posted as we learn more.
Posted Mar 27, 2026 - 13:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2026 - 21:23 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 26, 2026 - 21:19 UTC
Investigating
Our engineering team is currently investigating an issue that is causing intermittent disruptions on the Arm/Insights platform. Please note that no statistical data is impacted by this incident—only platform access is affected. We are actively working to identify the root cause and implement a resolution.
Posted Mar 26, 2026 - 20:31 UTC
This incident affects: Components & Services (Insights Dashboard, Insights APIs) and Live365 (Live365 Reporting).