US-CENTRAL network incident

Incident Report for SoundStack

Resolved

One of our upstream network providers (Level 3) experienced intermittent connectivity issues in the US-CENTRAL (Dallas) region, causing brief disruptions as traffic shifted between carriers. During these periods, alternate providers successfully handled most of the traffic.
Posted Jul 30, 2025 - 21:32 UTC

Monitoring

The network at our US-CENTRAL data center has stabilized, and services are operating normally.
We’re continuing to monitor the situation closely and will share more details as they become available.
Thank you for your continued patience and understanding.
Posted Jul 30, 2025 - 07:54 UTC

Investigating

We’re currently looking into a potential network issue at one of our US-CENTRAL data centers.
We will share more updates as soon as we have additional details.
Thank you for your patience and understanding!
Posted Jul 30, 2025 - 06:42 UTC