SoundStack and Live365 accounts services

Incident Report for SoundStack

Resolved

This incident has been resolved.
Posted May 19, 2026 - 15:36 UTC

Investigating

Some users might be experiencing difficulties accessing their accounts and logging in. Our engineering team is actively investigating the issue and working to resolve it as quickly as possible.
Posted May 19, 2026 - 13:37 UTC
This incident affected: Components & Services (Login Services).