Reporting Delay on Marketplace Dashboard

Incident Report for SoundStack

Resolved

We have confirmed that all reporting functionality for the monetize dashboard has been returned. Please get in touch with support@soundstack.com if you are still experiencing any issues or have any questions.
Posted Jun 17, 2025 - 16:51 UTC

Investigating

We are investigating a delay in data reporting from a demand partner. This delay is causing the publisher's monetize dashboard to be inaccurate and missing some data. This is not impacting ad performance and is only a delay in the statistics showing up on the dashboard. Once the reporting issue is resolved, all back stats will be returned to the dashboard.

Thank you for your patience as our team resolves this issue. Once all reporting is restored, we will update this status dashboard.
Posted Jun 15, 2025 - 14:57 UTC
This incident affected: Advertising (Monetize).