Live365 Streaming Network

Incident Report for SoundStack

Resolved

The issue impacting the Live365 Alexa integration has been fully resolved. All services are now operating normally. We’ll continue to monitor the platform to ensure stability. Thank you for your patience and understanding!
Posted Nov 06, 2025 - 20:32 UTC

Investigating

The issues affecting the Live365 Aggregator and BSS apps have been resolved. Our team is continuing to work on fully restoring the Alexa integration, which is still experiencing limited functionality. We’ll provide an update once this final component is fully resolved.
Posted Nov 06, 2025 - 14:11 UTC
This incident affected: Live365 (Live365 Applications).