Connectivity Issues Affecting EU Live Streaming

Incident Report for SoundStack

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2026 - 04:38 UTC

Identified

We have identified the issue as originating with an upstream provider supporting a portion of our European footprint. The provider is actively investigating the underlying connectivity issue. Impact remains limited to a subset of our Europe-based live streaming services, and we will continue to provide updates as more information becomes available.
Posted Aug 12, 2026 - 04:09 UTC

Investigating

SoundStack is currently investigating a network connectivity issue affecting a subset of our Europe-based live streaming services. The affected services are experiencing a service disruption while we work to identify the cause and restore normal connectivity. We will provide additional updates as more information becomes available.
Posted Aug 12, 2026 - 04:03 UTC
This incident affects: Content Delivery (Live Streaming Delivery - EU).