Live365 - Degraded Dashboard Functionality
Incident Report for SoundStack
Resolved
This incident has been resolved.
Posted Jul 25, 2022 - 13:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 25, 2022 - 13:12 UTC
Identified
We have identified an incident with the Live365 Dashboard functionality, which is causing some users to experience issues navigating their account. Our engineering team is investigating and should come to a resolution shortly.

Thank you for your patience!
Posted Jul 25, 2022 - 12:12 UTC
This incident affected: Live365 (Live365 Dashboard).