Internet Connectivity Instability

Incident Report for SoundStack

Monitoring

Network connectivity has remained stable following the earlier routing interruptions. Our investigation indicates that the issue was related to multiple upstream network events affecting select network paths.

Mitigations remain in place, and we are continuing to monitor network performance closely to ensure ongoing service stability.
Posted Jul 29, 2026 - 19:58 UTC

Investigating

We’re currently seeing intermittent connectivity interruptions affecting a portion of SoundStack services due to a network routing issue. Our team is actively working to restore normal traffic flow, and our built-in redundancy is helping to minimize customer impact. We’ll continue to monitor the situation and share updates as more information becomes available.
Posted Jul 29, 2026 - 19:24 UTC