Live365 Dashboard accessibility

Incident Report for SoundStack

Resolved

This incident has been resolved.
Posted Oct 31, 2025 - 00:12 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2025 - 21:56 UTC

Investigating

We’ve identified an issue affecting certain Live365 Dashboard functions, which may prevent some users from performing specific actions on their accounts.

Our engineering team is actively investigating to restore full functionality as quickly as possible.

Thank you for your patience and understanding.
Posted Oct 30, 2025 - 21:26 UTC
This incident affected: Live365 (Live365 Dashboard).