SoundStack and Live365 accounts services

Incident Report for SoundStack

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 19:59 UTC

Update

We are continuing to monitor the system closely and will provide further updates as needed.
Posted Dec 04, 2025 - 19:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 04, 2025 - 00:06 UTC

Investigating

Some users might be experiencing difficulties accessing their accounts and logging in. Our engineering team is actively investigating the issue and working to resolve it as quickly as possible.
Posted Dec 03, 2025 - 21:37 UTC