We are continuing to monitor for any further issues.
Posted Sep 12, 2026 - 22:10 UTC
Identified
We’ve identified the source of the connectivity issues affecting a portion of SoundStack services in the US-WEST region and have taken mitigation steps. Traffic is beginning to stabilize, and our team is closely monitoring recovery.
We’ll provide another update as the situation progresses.
Posted Sep 12, 2026 - 21:33 UTC
Investigating
We’re currently experiencing intermittent connectivity issues affecting a portion of SoundStack services in the US-WEST region due to a network routing issue.
Our team is actively working to restore normal traffic flow. Built-in redundancy is helping minimize customer impact while we work toward full resolution.
We’re closely monitoring the situation and will provide additional updates as more information becomes available.
Posted Sep 12, 2026 - 21:08 UTC
This incident affected: Content Delivery (Live Streaming Delivery - US-WEST).