Brief Upstream Connectivity Disruption – US-CENTRAL

Incident Report for SoundStack

Resolved

We’ve identified that the issue was caused by an upstream provider. The incident has now been resolved, and we’re actively working with the provider to ensure measures are in place to prevent a recurrence.
Posted Oct 31, 2025 - 21:38 UTC

Monitoring

Some streams and services hosted in the US-Central region may have experienced intermittent connectivity issues as routing reconverged. Our team has implemented corrective measures and is moving the incident to Monitoring while we continue to observe the situation to ensure stability.
Posted Oct 31, 2025 - 14:55 UTC

Investigating

Our team is currently investigating a network incident affecting one of our sites in the US-Central region. We will provide more details as they become available.
Posted Oct 31, 2025 - 13:19 UTC
This incident affected: Content Delivery (Live Streaming Delivery - US-CENTRAL) and Components & Services (Windows Servers).