Following a period of continued monitoring, network connectivity remains stable, and all services are operating as expected. No additional impact related to this incident has been observed. We are considering this incident resolved and will continue to monitor network performance as part of our standard operations.
Posted Aug 23, 2026 - 20:24 UTC
Monitoring
Service connectivity has remained stable, with no further interruptions observed at this time. The earlier disruption appears to have been caused by upstream network events impacting certain traffic routes. Our team continues to monitor network conditions closely to confirm services remain stable.
Posted Aug 23, 2026 - 03:33 UTC
Investigating
We’re currently experiencing intermittent connectivity issues affecting a portion of SoundStack services due to a network routing issue. Our team is actively working to restore normal traffic flow, while built-in redundancy is helping minimize customer impact. We’re closely monitoring the situation and will provide additional updates as more information becomes available.